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 The Spider System Setup Document

How to setup Spider: Shepard, Serv-U FTP, SpClient, NetPal etc.

This document shows how to set-up every aspect of Spider, and there are many.

There are two sides of a Spider setup, the server side and the client side. A server system is located at
every location where lots of production is done. A client is located at every site that receives audio and
programming from a server.

Let's Pretend...

For purpose of example we'll need a few fictitious stations in various towns. Let's put the hub in Hubville,
and one client in Univille, another client in Duoville and finally, one more client in Triville.

Terms

Among Radio, the Internet, telephones, computer hardware and computer software, there is enough
specialized jargon to make Noah Webster spin in his grave. Here is a list of terms with which you should
be familiar:

Server Usually refers to the machine that serves files to the
internet. It is sometimes referred to as the FTP-Server or
Shepard (since SHEPARD.EXE runs on this machine).

Client Machine running the SPCLIENT.EXE program. There is
one of these machines at every site that receives audio
from a server. It is networked to the SMARTCASTERs
via Lantastic.

FTP (F)ile (T)ransfer (P)rotocol. This is the "language" that the
Server and the Client speak in order to send and receive
data.

SERV-U FTP Server A program made by CatSoft (www.catsoft.com) that turns
a windows computer into an FTP server.

NetPal A dialer program that is used to supplement Window's
own internal dial-up adapter. Any Windows computer can
be set up to call the internet via modem, but the dialer
within Windows does not automatically re-connect if the
line drops. NetPal takes up that slack and makes sure that
the dial-up connection stays in place.

NetPal is make by a company called Kookabura Software
(www.kburra.com)
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Dial-up Adapter This is Microsoft-speak for "modem". It is a collection of
programs that allows the computer to connect its modem
to other modems. All machines that use modems (not
cable modems), must have dial-up networking installed on
them.

HUB The term hub can refer to a box that all networking cable
is routed to, or it can refer to the station where all the
production is generated for distrubution.

The Production Hub

Every group of stations has at least one Hub where a large amount of production is done.

This Hub must have a SMARTCASTER that is a dedicated production unit. By dedicated, I mean that this
system cannot do unattended records, play-back to air or any other function the record screen and cut
manager. This is because audio cuts recorded for Spider distribution are recorded with the enhanced
directories feature disabled (recording the audio directly under the directory titled AUDIO).

Production that is done for the local station only is done with the enhanced directory feature enabled. This
allows for the existence of two completely different sets of audio cuts. This is necessary because,
depending on the number of stations, it is very likely that a cut that is recorded to be distributed via spider
conflicts with the same cut number on the local cut inventory. In other words, if I want to send 00131 to
Univille, but Hubville (where I do my production) already has a 00131 that is completely different, I don't
want to record over my local copy of 00131.

The Production system hold the main user interface for the Spider. This interface is built into
SMARTCASTER. While this is the interface the user sees most often, the majority of the actual work is
done on the Shepard/Server unit.

The Server unit is a Windows computer that is running several programs:

SHEPARD.EXE●   

SERV-U FTP File Server●   

NET-PAL (This program is not run, however, if the customer has a non-dialup connection to the
internet, i.e. cable modem, ISDN etc.)

●   

The Server unit must share its local C> drive with the rest of the LAN network. This is to allow the
SMARTCASTERS access to the C> drive so that they can transfer audio cuts to it for Spider distribution.
The following list assumes

that you have a new computer with a modem and a freshly installed copy of Windows (95/98).●   

That you have already loaded Lantastic networking.●   

Most machines come with Dial-up networking already installed. Just in case your computer doesn't have it
installed, I've included the next section. To see if you have dialup networking already installed, double
click My Computer and see if there is an icon titled Dialup Networking. If so, skip the section titled "To
Install Dial-Up Networking." If you do not see a Dialup Networking ICON, follow these steps:

To Install Dial-up Networking:

Double-Click My COMPUTER The My COMPUTER dialog appears

Double-Click Control Panel The Control Panel appears

Double Click ADD-REMOVE Programs The Add-remove programs dialog appears

Click on the Windows Setup Tab The Windows Setup Tab appears
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Scroll down to COMMUNICATIONS and
double click it.

The Communications settings appear

Click on the box to the left of Dial-up
Networking.

A check mark appears in the box

Click on OK Windows prompts you to insert the Windows
95/98 CDROM.

Insert the CD Rom or (if you've installed the
Windows CAB files to a directory on your hard
drive), navigate to the directory containing the
Windows installation CAB files. Then click on
OK

Windows copies the files necessary for dialup
networking. Upon completion, Windows insists
on re-booting the computer.

When the re-start message appears, go ahead and
allow windows to restart the machine. Upon
completion of the re-start, dialup networking is
available and you are ready to add a dial-up
connection. Proceed to the next setup
walkthrough below:

 

Adding a Dial-up Connection:

Even if you have dialup networking installed, you must still create a new dial-up connection. To do so,
follow these steps:

Double click on MY COMPUTER The My Computer Dialog box appears

Double click on Dial-up networking The Dialup Networking box appears

Double click on MAKE NEW CONNECTION A MAKE NEW CONNECTION Wizard
appears.

In the edit box under the label "Type a name for
the computer you are dialing," enter the name of
your internet provider. This name does not have
to be an exact match, this is just for your own
reference.

The name appears in the edit box as you type

Press the [TAB] key The Cursor jumps down to the edit box under the
label "Select a device."

Click on the down arrow to the right of the
"Select a device" edit box.

A drop-down list of modems appears

Select the type of modem that you have.

Note: On some cantankerous Windows systems,
an extra modem is seen in this box, but doesn't
really exist. In this case, choose the modem from
this list that is the same name-brand as the one
connected to the Spider machine.

At the time of the writing of this document,
SMARTS' standard modem is an U.S. Robotics
External modem.

The drop down box disappears and the correct
modem name shows in the box under the "select
a device" label.
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Click NEXT A box appears prompting you to "Type the
phone number for the computer you want to call"

In the box labeled Area code, enter the area code
of your internet provider.

The area code appears as you type

In the box labeled Phone Number, enter the
telephone number of your internet provider

The phone number appears as you type. If you
wish to enter the dashes and parentheses you
may, but it is not required.

Click Next A message box appears saying that you have
successfully completed the creation of a new
dialup connection.

Click Finish. The box disappears.

Your connection is made. You are now ready to
install NETPAL.

Installing and configuring Net-Pal:

Please note that it is not necessary to install NETPAL on a system that does not use Dial-up networking to
connect to the internet. Among these types are: Cable modems, ISDN lines or T1 lines.

Run the SETUP.EXE program for NETPAL.
Accept all the default settings.

Once NETPAL is installed, go ahead and run it
by clicking on START>Programs >NETPAL >
NETPAL

The NETPAL program appears:

Most of the time, there is only one connection to
choose. (in the picture, the only connection
available is called "My Connection".

Sometimes, however, there may be several
connections to choose from. Netpal can only use
one of these connections at a time.

So, select the connection that you wish to use
(left click on the title under Connections).

The connection is selected (as shown above).
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Now click CONNECTION > TOGGLE
AUTODIAL

The connection now shows a lightning bolt to the
left of the connection title:

Now click View>Options The Option box appears:

Make sure that the following items are checked:

Redial Connections●   

Minimize On Connect●   

Copy IP to Clipboard●   

Add icon to taskbar tray●   

Run on Windows Start-up●   

Auto Reconnect●   

Make sure the following are not checked:

Restore Window State●   

Disable if autodialed●   

In the Interval boxes, make sure that the minutes
box is set to 0 and that the seconds box is set to 3.

Upon completion, your screen should look like
the picture above.

Click on OK The "global options" box disappears.
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Click on Connection > Connection Options The Connection Options dialog box appears:

In the Username box, enter the username for your
internet account

The username appears as you type

In the first Password, enter the password for your
internet account. This password is provided by
your Internet Provider

Note: As you type your password, you will not
see what you are typing. Instead, you see *'s. This
is a security measure to make sure that no one is
spying over your shoulder with a telescope to get
your password. The problem with not being able
to see what you type is that you could make
typo's. To guard against this, your are asked to
enter the password twice once in the first box, and
once again in the box to the right. Both of these
passwords must match exactly for NETPAL to
accept them as valid.

Click on the PING tab The Ping options appear:

Click on "Ping DNS server" and set the Interval
to 1 minute. Make sure that the "Don't ping if
auto-dialed" is not checked.

Finally, click on OK

The Properties box disappears.

Smarts Broadcast Systems - Spider System Setup

http://www.smartsbroadcast.com/support/spiderman.htm (6 of 29) [6/21/2002 10:49:05 AM]



Netpal is now installed. With the auto-dial
already toggled on, it is probably tying to call the
internet right now, if not click on the green phone
to activate it.

 

To Setup a Spider Shepard System:

 

Insert the first disk of the Audio Shepard install
set, and run the SETUP.EXE on the A: Drive.

A standard Windows installation routine begins.
Accept all default settings

Click on START>Programs>MS DOS PROMPT The DOS windows appears. Your cursor should
say C:\WINDOWS>

Type CD\ and press [ENTER] The prompt changes to C:\>

Type MD STATIONS and press [ENTER] The C:> prompt appears again

Type MD SHEPARD and press [ENTER] The C> prompt appears again

Type CD STATIONS and press [ENTER] The C> prompt changes to C:\STATIONS>

Now we get to make a directory for every town
(or every location that houses a CLIENT unit).
As per our example, we'd create a directory for
Hubville, Univille, Duoville and Triville Type
this:

MD HUBVILLE (press [ENTER])

MD UNIVILLE (press [ENTER])

MD DUOVILLE (press [ENTER])

MD TRIVILLE (press [ENTER])

Obviously, I am using the example names. We'd
want to substitute the proper names.

Note: Keep the town names to 8 characters or
under. DOS (the operating system that the
SMARTCASTERS use) cannot work with file
names that are longer than 8 characters.

As you type each of these commands, the
C:\STATIONS> prompt appears.

Now, we must create a special directory under
each of these for each station.

For the sake of simplicity, lets say that Univille
and Duoville both have only one station, but that
Triville is an AM/FM and has two stations.

In that case we'd do the following:

Type CD HUBVILLE (press [ENTER])

 

 

The prompt changes to
C:\STATIONS\HUBVILLE>
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Type MD KAAA (press [ENTER]) The C:\STATIONS\HUBVILLE> prompt
appears again

Type CD .. The prompt changes to C:\STATIONS\>

Type CD UNIVILLE The prompt changes to
C:\STATIONS\UNIVILLE>

Type MD KBBB (press [ENTER]) The C:\STATIONS\UNIVILLE> prompt
appears again

Type CD .. The Prompt changes back to C:\STATIONS>

Type CD DUOVILLE (press [ENTER]) The prompt changes to
C:\STATIONS\DUOVILLE>

Type MD KCCC (press [ENTER]) The C:\STATIONS\DUOVILLE> prompt
appears again

Type CD .. The prompt changes to C:\STATIONS>

Type CD TRIVILLE (press [ENTER]) The prompt changes to
C:\STATIONS\TRIVILLE>

Type MD KDDD-AM (press [ENTER]) The C:\STATIONS\TRIVILLE> prompt appears
again.

Type MD KDDD-FM (press [ENTER]) The C:\STATIONS\TRIVILLE> prompt appears
again.

Type CD\ The prompt changes to C:\>

By this point we've created a directory structure
containing a directory for each station group and
(under these) a directory for each station.

C:\Stations\Hubville●   

KAAA●   

C:\Stations\Univille●   

KBBB●   

C:\Stations\Duoville●   

KCCC●   

C:\Stations\Triville●   

KDDD-AM●   

KDDD-FM●   

Now, type CD SHEPARD (press [ENTER])

The prompt changes to C:\SHEPARD>
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Next, in this (shepard) directory, we need to
make a similar directory structure to the structure
that is under STATIONS. The difference is that
the directories under SHEPARD do not have the
individual station directories under the "town"
directories.

This directory is the one that is shared with the
whole Internet world via FTP. These directories
are actually the FTP accounts used by the
SERV-U FTP file server. Each station group has
one SpClient machine and therefore needs only
one FTP account for the entire group.

To further illustrate, let's use the example that
we've created. Hubville, Univille and Duoville
have one station per town. Each of these station
groups happen to be groups of one. Triville,
however, is a station group containing two
stations. Even though Triville has two stations, it
is still just one group so it gets one account
called Triville.

To implement our example, type the following:

MD HUBVILLE (press [ENTER])

The prompt C:\SHEPARD> appears agin

Type MD UNIVILLE (press [ENTER]) The prompt C:\SHEPARD> appears again

Type MD DUOVILLE (press [ENTER]) The prompt C:\SHEPARD> appears again

Type MD TRIVILLE (press [ENTER]) The prompt C:\SHEPARD> appears again

Now, type EXIT and press [ENTER] The MS-DOS screen disappears and you are
back to the Windows desktop.

Sharing C> drive on the Shepard machine with the rest of the LAN Network

To use the directories that we've created, we must make sure that the C> drive of the Server/Shepard unit
is shared with the rest of the network.

Double Click on My Computer My Computer box appears

Right Click on C> drive A popup menu appears
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Left click on Lantastic Sharing A share menu activates.

Click on the SHARE button The Add Resource Dialog box appears:

In the resource name field, enter C-DRIVE. Upon completion, the box should look like this:

Now click on CREATE Lantastic shows a progress bar for a second or
two then disappears. Your C-drive is now shared
with the Local Area Network.

To Setup SERV-U FTP file Server

Run the SETUP.EXE program for SERV-U This runs through a standard Windows setup
routine. Please use all default settings.
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Once finished with the setup, select
START>Programs>SERV-U> Serv-U FTP
Server

This runs SERV-U for the first time. You'll see
two choices.

Click the "I AGREE" button in the Choice 1
box.

The Choice screen disappears leaving the main
SERV-U screen.
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Now, click on SETUP>Users The Users screen appears:

Now we get to create accounts for each of the
station groups. There will be one of these
accounts for each of the stations listed under the
Shepard Directory we created before.

Click on the NEW button on the right hand side
of the screen.

A dialog box pops up asking for the username.

In the Username field, type hubville "hubville" appears in the Username box

Note: The name in the Username box is case
sensitive. Please use all lower case.

Click on OK The word hubville appears in the USERNAME
field as well as the list of users on the left hand
side of the screen.

Click on the PASSWORD field The cursor blinks in the password field

Establish the password for the Hubville account.
You get to make this up, just don't forget it! As
a matter of fact, call SMARTS for our naming
convention.

Note: The password field is CASE Sensitive. Be
sure to always use lower case.

Now [TAB] down to the HOME DIRECTORY
field and enter C:\SHEPARD\HUBVILLE

The name appears as you type it

Next, click on the ADD button at the bottom of
this screen.

The PATH NAME entry box appears

Enter into this path name the same path you
entered before:

Type C:\SHEPARD\HUBVILLE and press
[ENTER]

The entry box disappears, and the directory
information is entered in the file/directory access
rules box.
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Just to the right of the File/Directory Access
Rules box, there is a column of options. Of
these options, be sure the following are
checked:

Read●   

Write●   

Delete●   

List●   

Make●   

Remove●   

Be sure that Execute is not selected.

When finished, it should look like this:

Repeat the steps again (starting with pressing
the NEW button) for each of the group's
accounts.

When completely finished, it should look like
this:

Congratulations! You've just installed and configured Serv-U ftp file server. The only thing remaining
with the FTP portion is to make sure that SERV-U ftp server comes up every time the system boots.

To Add Serv-U FTP file server to the Windows Startup Folder

Right-Click the START button A popup menu appears

Click on OPEN A "Program Manager" style box opens
displaying the contents of the START menu in
editable boxes.
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Double click on PROGRAMS The list of items under Programs appears

Double Click on SERV-U Ftp Server Option The contents of the SERV-U Ftp Server appear

RIGHT Click the icon called SERV-U (it's the
one with the big green U)

A popup menu appears

Left click on COPY The popup menu disappears

Click on the "x" in the upper right hand corner of
this box

The Box disappears

Right Click on START again The popup menu re-appears

Left click on OPEN The contents of the menu bar display themselves
again.

Double click on Programs The contents of the Programs folder are
displayed

Double click on the STARTUP folder The contents (if any) of the Startup folder are
displayed

RIGHT click on the "white space" inside this
box

A popup menu appears

Left click on PASTE The Serv-u icon appears

Click on the "x" in the upper right hand corner of
this box

The box disappears

Now, when Windows starts, Serv-U FTP server
will start automatically

The last and most important thing to do with this machine is to install the SHEPARD program.

Run the SHEPARD Setup program There is a standard Windows install. Choose all
default settings

Once installed, click on
START>Shepard>Shepard

The Shepard program starts:
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Click on SETUP>RADIO STATION SETUP
LIST

The Setup screen appears:

Now the tedious part... you must make an entry
for each station not station group. For instance,
in our example, we would have to make a
separate entry for

KAAA

KBBB

KCCC

KDDD-AM

KDDD-FM

You may notice as you fill in the blanks that the
FUNCTION and FCTN INDEX fields alter
themselves. This is designed to automatically
accommodate groups with multiple stations
whose functions (liners, jingles etc.) need to be
sent to unique locations. The path portion within
this field alters itself, you must still supply the
correct drive letter

Note: the paths listed in the Destination Panel are
path names that make sense to the SpClient
machine, not to the Shepard machine. In other
words: in the Breaklog edit box in the
Destination panel, I enter "Z:\AUDIO". This Z
drive is the Z drive on the SpClent machine. This
Z drive has nothing to do with the SHEPARD
machine.

When you get to the INDEX box in the
SOURCE panel, enter the index path used by
the SMARTCASTERS at the HUB site. This is
the path from which SHEPARD takes the source
index.

 

Example Entry:
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When finished with each entry, click on DONE. The Station Setup Screen disappears.

Repeat these steps until there is one entry for
each station in the whole spider system.

 

That completes the work for the Shepard Machine, but does not complete everything necessary for the hub
site. The next thing we need to do is configure the dedicated production unit.

To Setup the Dedicated Production Unit:

Exit to the C> prompt and type CD\LANTASTI
and press [ENTER]

The prompt changes to C:\LANTASTI>

Type EDIT CONNECT.BAT and press
[ENTER].

The DOS Editor shows the contents of
CONNECT.BAT

In the NET USE/REPLACE section of the
CONNECT.BAT, add a line that logs into the
Shepard machine.

This example assumes that the Shepard machine
is called NT-SPIDER on the network. If your
machine name is different, please substitute its
name for NT-SPIDER.

Note that I am also assuming that S:> drive is
free on the network. Again, it is not, you'll need
to substitute a drive letter that is free.

Add the line:

NET USE/REPLACE S:
\\LT-SPIDER\C-DRIVE

The line appears as you type it
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Now select FILE>Exit A message box pops up saying, "Loaded file is
not saved, save it now?"

Answer YES by pressing the "Y" key. The DOS editor closes

Type the word CONNECT and press [ENTER] The system re-connects to all network drives
including the newly created S: drive.

Type GSETUP.

It may be necessary to enter a password here. If
you are prompted for a password, call SMARTS
to get it.

The setup screen appears

Option 1 states: Is the internet "gateway" mode
active on this system?

Type 1 and press [ENTER]

The Cursor is now under the N

Type Y and press [ENTER] Option 1 now shows a "Y" under the value
column.

Type 2 and press [ENTER] The cursor appears under the value entered into
the "Drive Letter where \Stations Directory is"
entry.

Type the drive letter entered earlier in the
CONNECT.BAT for the LT-SPIDER C:> drive.
Using our example, we'd type "S" and press
[ENTER]

The letter appears in the VALUE column

Press [ESC] The Setup screen Disappars

Note: Number three in this setup screen on the
dedicated production machine should be set to
No. This option is for use by machines other
than the dedicated production system. See the
next section for details on this type of setup.

Type GO and press [ENTER].

 

To Enable All other machines to be able to transfer audio via Spider

While the dedicated production room unit is able to record audio specifically for Spider transfer, it is still
possible for other SMARTCASTERS to send cuts via Spider. They have one major limitation, however.
Any audio sent by the non-dedicated production unit is audio that is in the local spot inventory for the hub
station. Most of the time this limitation is not a big deal, but it could be a big hassle if the client station and
the hub station have a spot-number conflict (i.e. 00131 is a different account for each station).

To set this up, do the following:

At the C> prompt of the SMARTCASTER (not
the dedicated production room unit), Type
GSETUP and press [ENTER]

The setup screen appears

Make sure that Option 1 is set to N.

Next type the number 2 and press [ENTER]

The cursor is blinking under the second item in
the VALUE column
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Enter the drive letter that is re-directed to the C>
drive of the SPIDER ("S" in our example) and
press [ENTER]

The Drive letter appears

Type the number 3 and press [ENTER] The Cursor appears under the third item in the
value column

Type "Y" and press [ENTER] The third option is now set to Y

Press [ESC] to exit The setup screen disappears

Type GO and press enter The Main menu appears

This concludes all the setup that is necessary for the Hub system. The next topic is what to do at the client
station.

Once again, I'll make the assumption that you have a Windows machine with Lantastic already loaded and
running. Dial-up networking must be installed and operating on this unit (if they connect to the internet via
modem), but it is not necessary to install Net-Pal. The SpClient systems log in to the Shepard machines at
set intervals. If a line disconnect occurs during one session, SpClient discards that session and tries again
during the next login.

To Move the CD ROM to another Drive Letter:

The SpClient system must have its drive re-directions the same as the re-directions on the
SMARTCASTERS. Unfortunately, Windows defaults the CD-ROM drive to the first available drive letter
(usually D). Before we do anything else, we have to move the CD-ROM drive letter to allow us to make
up the drive re-directions.

Right Click My Computer A popup menu appears

Left Click Properties The SYSTEM Properties dialog appears

Click on Device Manager A list of system devices is shown

Click on the + sign to the left of CD-ROM A list of CD-ROMs installed on the system
appears.

Click on the CD-ROM whos drive we wish to
change

The CD-Rom is selected

Click on Properties The CD-ROM's properties are shown

Click the SETTINGS Tab The settings are shown:
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Select the down arrow to the right of START
DRIVE LETTER.

A list of letters appears

Choose the drive letter you wish the CD-rom to
use. The letter has to be one that is not used by
the SMARTCASTER.

For example, if the SMARTCASTER were
using drives D, E, F, G, H, X, Y and Z, none of
these letters could be used for the CD-ROM on
the SpClient. For our example, I'll use Q:.

That letter appears in both boxes:

Click on OK The system will re-boot with the new drive
settings intact.

Now that the CD-ROM is out of the way, we have to connect the SpClient system to the LAN network.
Remember, all drive letters are in common with the SMARTCASTER's redirections.

To Re-Direct drives in Windows:
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Step 1 is to determine what drives are on the
SMARTCASTER, and what mapping it uses.

If the SMARTCASTER(s) are already setup, go
to the SMARTCASTER unit and select QUIT >
ABOUT.

Within the ABOUT screen, press the "N" key.
This shows the contents of the
SMARTCASTER's CONNECT.BAT.

Now, page down to the end of this file listing
until you see entries such as this:

Net Use/replace d: \\server\d-drive

Net Use/replace e: \\server\e-drive

...

Write down this list of drive re-directions. When
you're done, take the list to the Spclient
machine.

Now Right Click Network Neighborhood

The Network Neighborhood dialog box appears.

This shows you a list of computers that the
Spclient machine sees over the LAN network.

Refer to the list of drives. Find the machine
names on this list. The machine names are the
name after the "\\" portion of the command

Now, double click the machine's icon.

A box opens showing you the contents of that
machine. All hard drives and printers that are
being shared by the machine are displayed here
as file folders.

Find the first drive that we need to connect the
SpClient machine to.

(In our example D: is connected to
\\SERVER\D-drive, so we want to locate the
folder called D-drive)

Now RIGHT click the ICON

A popup menu appears

Left click on the option entitled MAP
NETWORK DRIVE

This box appears:

The Drive box should already have the first
drive available on your system. If this is not the
correct drive, click on the down arrow to the
right of the drive box and choose the correct
one.

Once you've verified that the drive letter is
correct, check the box to the left of
Re-CONNECT AT LOGON.

A check mark appears in the box. If there is
already a check in the box, there is no need to
click it.
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Click on OK The "Map Network Drive" box disappears and
the contents of our new drive appears.

Click on the "x" in the upper right hand corner
of this box

The box disappears

Repeat these steps as necessary to map all of
your network drives.

 

Most SpClient machines connect to the internet via Dialup connection. If Dial-up networking has not been
installed on this machine, please follow the previous instructions on how to setup dialup networking.
Likewise, if a new dialup connection must be created, do so now according to the instructions for creating
a new dialup connection.

Once all these steps have been complteted, the SpClient machine is prepared. All that remains is to setup
SpClient. Follow these steps:

Follow the instructions earlier on how to Add a
new dialup connection

 

Run the SpClient SETUP.EXE program A standard Windows setup dialog appears.
Please accept all defaults.

Now, run the SpClient program by clicking on
START>Programs>SPCLIENT> SPCLIENT.

The SpClient program appears:

Click on File>Dive Setup The Drive Setup dialog box appears:
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Choose C: drive and click the LOCK button The button presses in and appears locked. This
prevents Spider from seeing C drive as a valid
drive to which audio could transfer.

Our goal is to lock out all drives that are seen by
the SpClient machine that are not used by the
SMARTCASTER to store audio. Usually, this is
limited to the C drive of the SpClient machine as
well as its CD-ROM drive.

Now that we have C> drive locked out, select
the CD-ROM drive by Clicking on the down
arrow to the right of the Drive information box.

A dropdown box appears, listing all drives seen
by SpClient

Scroll down until you see the icon of the
CD-ROM drive. Click on this Icon

The dropdown box disappears and the CD-ROM
is selected.

Click on the LOCK button. The CD-ROM is now locked.

Now click on File > Add or Edit an Event The Add/Edit screen appears:

Click on ADD The cursor jumps over to the blank under IP
ADDRESS.

Enter the IP address of the server system. This
number is provided by the internet provider of
the Shepard system. The IP Address usually has
four sets of numbers separated by periods (such
as: 111.111.111.111)

The IP Address appears in the field as you type
it.

Enter the Username (remember, no capital
letters).

Enter the Password

In the SOURCE blank, enter *.TRN (this time,
use all capital letters).

This indicates to SpClient which files it should
download from the FTP file server.
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In the TIME field, enter in a time when you wish
this event to occur.

12:30

If you wish this event to occur every hour, enter:

**:30

If you want this event to occur every ten
minutes, enter:

**:*0

If there are several SpClient systems that log
into one FTP server, it is a good idea to stagger
the times that they do so. Tell the first SpClient
machine to log in at :10 after each hour, the next
SpClient to log in at :20 after each hour etc. That
way the server stays as dedicated as possible to
one client at a time and will decrease download
time.

 

The Buttons for each day of the week default to
on. If for some reason, you want to exclude this
event from a certain day, toggle that day's button
to the off position.

In the TITLE box, give this event a meaningful
name. This is most useful for a station that has
many different events to manage.

 

In the AM I panel, indicate that you are
downloading

The selection dot appears to the left of
"Downloading specified files".

In the, "What do I do with the source file" panel,
indicate that you want to "Delete it" by clicking
on the circle to the left of "Delete it."

The selection dot appears within the circle

Finally, click on DONE The Event Entry box disappears and the Spider
client's main screen appears.

If any of the events that you've scheduled fall
within the current hour, you'll see a green pie
chart slice on the clock within the "big purple
egg" on the right side of the screen. This is just a
visual indicator of when the next event is going
to take place.
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The "happy spider" picture is the default picture
that comes with the spider machine. If you have
a logo or any other picture that you want to use
instead, be sure that the file is saved in a BMP
format. Then rename the file to a file called
SMLOGO with no extension Finally, copy the
file into the C:\Program files\spclient folder.

When SpClient is closed and re-started, the new
graphic will show instead of the spider.

 

Ok, now we have Spider's main functions up and online. A person who sits at the dedicated production
room in Hubville can record an audio cut and transfer it across the Internet to any or all of the SpClient
machines. But what if the person in the field has a spot that she wants to send to someone else on the
network?

Setting up Lateral Transfer

To accommodate this need, something called LATERAL transfer was developed. Lateral Transfer is
slower than normal internet distribution since it must send audio back to the hub station for re-distribution.
Lateral transfer is intended for the occasional spot or sound bite. If the station is producing a large number
of audio cuts for distribution across the Internet, it should house a Shepard system.

Setting up Lateral transfer involves changes at each of the client sites and the server (hub) site.

Lateral transfer works by allowing a SMARTCASTER that is hooked to an SPCLIENT machine to copy
an audio cut across the internet and place it in the stations directories just as the dedicated production
room computer does. This means that any audio cut that is sent to the hub is actually sent several times, so
this process can be time consuming.

The first changes need to take place on the Shepard machine.

Double-Click on the Green "U" in the lower
right-hand corner of the screen.

The SERV-U ftp file server appears
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Click on SETUP > USERS The Users Setup appears:

A lateral-transfer cut is sent via the internet
back to the hub and straight into the "stations"
set of directories. In order to make this possible,
we have to create FTP accounts that connect to
these station directories.

SMARTS's naming convention is to call these
accounts the name of the town with the letter R
in from of them (R for Reverse).

So, to setup our lateral transfer to Hubville,
click on the NEW button

A box appears asking for the NEW NAME

Type in "rhubville" and click on Ok.
(remember, no caps)

The Box disappears and account information for
rhubville appears

Click on Password The cursor flashes in the Password blank

Enter the password (no caps) The password appears in the box

[TAB] down to "Home Directory" The cursor flashes in the home directory box.

Type in C:\STATIONS\HUBVILLE then click
ADD (from the bottom of the form).

The PATH NAME box appears

Enter C:\STATIONS\HUBVILLE and press
[ENTER]

The box disappears

Be sure that the following items are checked:

Read●   

Write●   

Delete●   

List●   

Make●   

Remove●   

Inherit●   

Be sure that execute is not checked.

Click on NEW and repeat these steps for each
of the station group names

You'll see the names of the accounts appear on
the left hand side of the screen in alphabetical
order.
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When finished, click OK The User setup screen disappears.

Minimize Serv-U ftp sever by clicking on the
"-" sign in the upper right hand corner of the
form.

The form disappears

The last step for this machine is to follow the instructions for installing and configuring SpClient. Since
we can lateral transfer, there must be a copy of the client software running on this machine to extract files
sent by other stations. You will need to move the CD-ROM drive and set up all the drive re-directions on
the Shepard unit. Even though this is still a Shepard unit, we also treat it as an SpClient machine.

No other changes are needed at the hub end. The rest take place in the field.

On the SpClient machine, make sure that the C drive is shared across the LAN network. This drive will
hold the STATIONS directory used for lateral transfers. Once the drive is shared, follow these
instructions:

Click on START > Programs > MS-DOS
prompt

The C:\WINDOWS> prompt appears

Type CD\ and press [ENTER] C:> prompt appears

Type MD STATIONS and press [ENTER] C:> prompt appears

Type CD STATIONS and press [ENTER] C:\STATIONS> prompt appears

Now we need to make a directory for every
station group except the group to which this
SpClient computer belongs. We have no need to
lateral transfer back to ourselves.

In other words, if I am configuring lateral
transfer in Univille, I do not want to create a
directory for Univille.

Let's assume that we are configuring the
Univille SpClient system.

Type MD DUOVILLE and press [ENTER]

C:\STATIONS> prompt appears

Type MD TRIVILLE and press [ENTER] C:\STATIONS> prompt appears

Type MD HUBVILLE and press [ENTER] C:\STATIONS> prompt appears

Type EXIT and press [ENTER] The MS-DOS box disappears and you are
returned to the Window's desktop.
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Now start the SpClient program The SpClient screen appears:

Click on File>Add Lateral X-fer event The Add Lateral Event screen appears:

Enter the IP address of the server system into the
first blank

 

Enter the username for the lateral account into
the second blank (rhubville for our example).

 

Enter the Password into the password blank

In the source field, enter
C:\STATIONS\HUBVILLE

Upon completion your screen should look like
this:

Click on CLOSE The Lateral Transfer Setup box disappears

Click on FILE > Add Lateral Transfer Event The Lateral Transfer Setup Box re-appears
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Repeat these steps as necessary until you have
created an entry for each station group (except
the one that owns the spClient machine you are
programming).

 

On each of the SMARTCASTERS at the client location, follow the steps outlined above for "To Enable
All other machines to be able to transfer audio via Spider." Once these settings are entered, a
SMARTCASTER can send a cut from Cut Manager to any other system on the Spider network.

Common problems and trouble-shooting Spider

The Spider system performs many functions and depends on several key pieces being in place. The
following are tips and tricks to help diagnose problems with the Spider system.

Cannot Write Socket errors.

This may be translated as: Cannot see across the internet to the FTP server. There are many things that can
cause this problem. Among these include:

The modem is turned off or unplugged●   

The modem is plugged into a non-dedicated phone line and someone else is using the line●   

You're not logging in correctly. Be sure that your username and password are set up correctly in
NETPAL. (See instructions above).

●   

Your internet provider is down for maintenance. Pay attention to e-mails that you get from your
provider. Most providers take extreme care to prevent downtime, but, in order to do this, they must
periodically take down servers on purpose to maintain them and update software. Most will e-mail a
planned outage schedule (especially if you request one from them).

●   

The Hub internet provider is down (same reasons)●   

The Internet is too slow. If you hit this error anywhere from 3:30 pm to 7:00 pm (aprox), it is likely
that one of the Internet providers (Hub or Client) is swamped with people logging in to their service.
It is possible that during such peak times that transfer rates could slow to a dead halt eventually
forcing the client to give up trying.

●   

I can connect and I can see files download, but when they are trying to transfer across to my
SMARTCASTER I get a RUNTIME Error 76.

Click on OK to clear the SpClient out of the way. Now click on My Computer. Check to make sure that
there are no large red "X" marks through any of the drive letters. If there are, double-click each of them to
see if Windows can re-establish the network connection. If it is successful in re-establishing the
connection, the contents of the drive will appear in a box (just click on the "x" in the upper right hand
corner to clear this form and repeat these steps for each of the drives).

If all else fails...

Try re-booting the computer. Spider makes use of both hardware and software and it is a good idea to
re-boot the system occasionally (perhaps once a week) to ensure reliable operation.
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